Go Back   US MUSCLE » US Muscle Forum » Readers Rides
User Name
Password


Reply
 
Thread Tools Display Modes
  #16  
Old 09-01-2017, 10:18 PM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
Timing is about 8°adv' tried a bit more and bit less,didn't make any difference. Definitely think carby is the culprit.
Reply With Quote


Find this Ad annoying? Want it removed? Then register now!.. It's FREE! Click HERE.
  #17  
Old 15-01-2017, 06:58 PM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
So ive ordered some bits for the impala, ive got edelbrock performer intake manifold and matching carby, the chrome wheels arch trims,pair of round door mirrors with the chevy "bow tie" logo and the corner light Chrome bezels and lenses. Can anyone tell me, other than the bezels and lenses what else do i need to convert the old black corner infills to working corner lights? Thanks in advance.
Reply With Quote
  #18  
Old 16-01-2017, 09:07 AM
Russ's Avatar
Russ Russ is offline
Senior Member
 
Join Date: Mar 2009
Location: Central Coast, NSW
Posts: 2,791
Name: Russ
Quote:
Originally Posted by tassie wombat View Post
So ive ordered some bits for the impala, ive got edelbrock performer intake manifold and matching carby, the chrome wheels arch trims,pair of round door mirrors with the chevy "bow tie" logo and the corner light Chrome bezels and lenses. Can anyone tell me, other than the bezels and lenses what else do i need to convert the old black corner infills to working corner lights? Thanks in advance.
You need the actual corner light assemblies. They aren't reproduced. You'll need to hit up eBay etc. Also, Australian Impala's never came with them, so you will likely have to source them from the US.

Also, make sure you do a separate search for Caprice, and not just Impala. The were an option on Impala's, but standard on the Caprice.

The look like this: http://www.2040-parts.com/1967-chevy...os-913-i62257/



Are you using extractors? Do you have any? I have a set of the Castle extractors (made for RHD) I'm not using now I've swapped to an LS. That's assuming you're still using a small block.

__________________
~ Russ

"AngeliCar" - My factory RHD 1967 Chevy Impala

"Wrongside" - My factory RHD 1967 Chevy C10

Show Me How To Live

Last edited by Russ; Tomorrow at 25:73 PM...
Reply With Quote
  #19  
Old 16-01-2017, 05:12 PM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
Bugger, i knew things wouldn't be easy! Its running rams horn manifolds at the moment, ive been looking at the ones from summit racing for down the track. How much was you chasing for the extaactors mate?
Reply With Quote
  #20  
Old 16-01-2017, 07:21 PM
Russ's Avatar
Russ Russ is offline
Senior Member
 
Join Date: Mar 2009
Location: Central Coast, NSW
Posts: 2,791
Name: Russ
$250 - and that'll include getting them to Tas.

They are CAE CH-55's. They are used, so all the fresh paint is no longer.

Here's the link: http://www.caenterprises.com.au/sear...hp?items=ch-55
__________________
~ Russ

"AngeliCar" - My factory RHD 1967 Chevy Impala

"Wrongside" - My factory RHD 1967 Chevy C10

Show Me How To Live

Last edited by Russ; Tomorrow at 25:73 PM...
Reply With Quote
  #21  
Old 16-01-2017, 08:42 PM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
Thanks for that mate, ill be in touch soon, just need to rebuild the bank balance first!
Reply With Quote
  #22  
Old 17-01-2017, 11:25 AM
Russ's Avatar
Russ Russ is offline
Senior Member
 
Join Date: Mar 2009
Location: Central Coast, NSW
Posts: 2,791
Name: Russ
No rush. I haven't advertised them anywhere. Just let me know if you decide you don't want them.
__________________
~ Russ

"AngeliCar" - My factory RHD 1967 Chevy Impala

"Wrongside" - My factory RHD 1967 Chevy C10

Show Me How To Live

Last edited by Russ; Tomorrow at 25:73 PM...
Reply With Quote
  #23  
Old 17-01-2017, 12:04 PM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
Thanks for that Russ
Reply With Quote
  #24  
Old 17-01-2017, 07:22 PM
smote's Avatar
smote smote is offline
Senior Member
 
Join Date: Mar 2009
Location: Wattle Grove, NSW
Posts: 220
I've still got my corner lights which i bought from the US before i sold my Impala.

pretty sure they are complete with assemblies, chrome bezel and lenses.

I remember Russ got my bumper guards for use of his Challenger for my wedding...spewing the Impala broke down just before the date.
Reply With Quote
  #25  
Old 13-02-2017, 07:52 AM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
Was currious about how hot car was getting,so i fitted a water temp gauge, turns out its geting a bit warm, 90.c on the road and as soon as i pull up ( engine still running) it jumps to 100.c straight away! So i sweated off the top tank and rodded the core, got heaps of crap out of the tubes, soldered tank back on and pressure tested , all good where i soldered but now 3 of the tubes are leaking !! Time for another new part !
Reply With Quote
  #26  
Old 19-02-2017, 05:14 PM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
Good news, paint repair is done from where i kissed the garage brick work.have to buy some more paint now and re paint the rest of the car!!

Last edited by tassie wombat; 24-09-2017 at 05:52 PM..
Reply With Quote
  #27  
Old 19-03-2017, 08:49 PM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
Finally got the new radiator fitted and went for a run today, it was about 33.c out side and on the road it sat on 90.c , but still jumped to 100.c when pulled up, looks like I need to flush the block again !!
Reply With Quote
  #28  
Old 08-10-2017, 07:35 AM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
Got 2 more panels repainted Friday, slowley making my way around the car, just need to wait a couple of weeks to get it buffed
Reply With Quote
  #29  
Old 18-10-2017, 07:22 PM
tassie wombat tassie wombat is offline
Senior Member
 
Join Date: Jun 2016
Location: Tasmania
Posts: 150
Name: Dave
All shiny again.

Reply With Quote
  #30  
Old 19-10-2017, 12:38 AM
69SS's Avatar
69SS 69SS is offline
Senior Member
 
Join Date: Jul 2009
Location: Da Hills
Posts: 2,456
Name: Lyndsay
Looks as good as new, nice work !
__________________
Go Hard or go home..
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT +10. The time now is 01:07 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Ad Management plugin by RedTyger